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Introduction
This manual describes a simple process for monitoring changes in forest cover using freely 
available satellite imagery. Rather than classifying satellite imagery, which usually involves 
downloading large files and complicated imagery processing steps, this approach relies on hand-
digitizing changes in forest cover from direct observation by comparing satellite imagery from 
different dates. This approach relies on the human eye to quickly distinguish between real land-
cover change and other differences like clouds, shadows, haze, and seasonal changes in vegetation 
appearance. All that is required is the freely available QGIS program, basic GIS skills, and a 
working knowledge of satellite image interpretation.

Accessing imagery
1. If you do not already have one, create a gmail account at 

https://accounts.google.com/Signup. 
2. Fill out a request for satellite image coverage specifying the area of interest and the time 

frame and submit to MJUMITA/TFCG at 
https://docs.google.com/forms/d/e/1FAIpQLSei_fl_N9XUaGEX7oGFrtZMvy8AGVzQNG
mk6WfqwsvnKkB3Ww/viewform?vc=0&c=0&w=1&usp=mail_form_link  .   Remember that 
a kml file of the forest(s) of interest can be created from a shapefile using the export option 
from QGIS.

3. Receive the XYZ connections xml file by email.
4. Load the XYZ connections in QGIS by opening the browser panel (found under the panel 

options in the View drop down menu) and right clicking on the XYZ Tiles Icon. Select 
“Load Connections” and then select the XYZ connections xml file sent by email. This only 
needs to be done once. After that, the image connections will always be available under the 
XYZ tiles list in the QGIS Browser.

5. If not already loaded, also load the XYZ connections xml file for Google Earth and Bing 
Satellite imagery which will also be provided by email. 

Digitizing non-forest and deforestation
1. Load the shapefile for the area of interest (e.g. Forest Reserve Boundary). Set the style to 

line only and set the line color to something like a bright green color.
2. Zoom to the area of interest in QGIS by right clicking on the shapefile in the layers panel 

and selecting Zoom to Layer. 
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3. Load the XYZ tiles into the layers panel by shift selecting all the desired connections and 
then right click and selecting Add selected Layers to Canvas.

4. Create a new polygon shapefile to store the non-forest area polygons. Include an whole 
number field called year with a length of 4, also optionally include a text field for notes and 
for land-cover class.

5. Turn on snapping to Vertex and Segment for All Layers. Set the snapping tolerance to 12 px.
6. Turn on editing of the new Shapefile Layer and start digitizing the non-forest areas in the 

oldest imagery provided. Make sure to include the correct year of the image in the year field 
for non-forest polygons. 

7. Once finished digitizing all non-forest areas in the oldest image, move on to the next and 
again remember to record the year for each new non-forest polygon. After digitizing all of 
the non-forest areas in the first year of the analysis, only digitize new non-forest areas for 
subsequent years. 

Digitizing Advice:
• Know the Tanzania definition of forest - Read the next section on this manual on defining 

forest and non-forest carefully.
• Make use of layer styles to aid interpretation - When digitizing, have a copy of the non-

forest area polygons open with a filled style with no pen and another copy open with a line 
only style. Have the line only version open for editing to add new non-forest areas and make
non-forest areas from past years opaque to make it easier to pick out new areas of non-
forest. Optionally use a categorized style to give each years non-forest areas a different fill 
and line color. 

• Always use snapping – It is very important that the non-forest polygons from one year do 
not overlap with the new non-forest polygons in a subsequent year.

• Use tracing carefully - Use the tracing feature in the QGIS snapping toolbar to 
automatically snap non-forest areas to each other and to the boundaries of the forest, but pay
close attention to make sure it is working as expected. If the tool does not behave as 
expected, delete the mis-snapped points and then add them using snapping with tracing 
turned off.  

• Save frequently - Save changes the non-forest polygon shapefile frequently to guard against
data loss in the event QGIS freezes or computer shuts down

• Use high resolution imagery to aid interpretation - Have XYZ connections open to 
Google Earth and Bing satellite imagery to aid in interpreting lower resolution satellite 
imagery. However, be aware that the dates of the Google Earth and Bing XYZ connections 
may be significantly different from the period being digitized. 

• Learn to understand false color imagery - Compared to natural color imagery, false color 
Sentinel-2 imagery (Figure 1 and Figure 2) makes it easier to distinguish differences in 
vegetation. Take time to familiarize yourself with the appearance of different forest and non-
forest land-covers in false color imagery by comparing with Google Earth and Bing imagery
or areas that you have been to on the ground. 

• Pay attention to texture - In addition to changes in color, changes in texture can also 
indicate land-cover change. Generally, non-forest areas will have a smoother appearance 
than forested areas.

• Patches of trees less 0.5 ha are not forest.
• Use the ring tool for patches greater than 0.5 - For isolated forest patches 0.5 ha or 

greater, the Add Ring tool in QGIS can be used to create a gap within a non-forest polygon 
to exclude the forest patch from the polygon. 
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Figure 1: Digitized non-forest areas from May 2016 Sentinel-2 imagery in two village forest 
reserves in Kilosa District



Defining forest
Non-Forest and Deforestation can be tricky to define. Tanzania has provided a definition to the 
UNFCCC for forests as areas at least 0.5 hectares with trees greater than 3 meters in height with 
10% tree canopy cover or more. NAFORMA defines other land as simply all land that is not defined
as Forest. Since other lands do not have a strict minimum area for their definition, it is not clear 
what the minimum size is for areas to be defined as non-forest. In practice, many researchers use a 
kind of reverse definition to define non-forest areas as areas with less than 10% tree canopy cover 
and a minimum size or 0.5 ha, which is also about the minimum size of an object that can be 
mapped reliably with Landsat data, equivalent to about 5 Landsat pixels. 

Sentinel-2 resolution is fine enough to pick up on the loss of individual large trees, but mapping all 
such losses would be extremely time consuming and most forests scientists would define such 
losses as degradation rather than deforestation. However, it is also difficult to know that an area is 
greater than 0.5 ha before digitizing it and once digitized, it doesn’t make sense to discard a 
digitized non-forest polygon. It should be noted that mapping smaller clearings should not greatly 
affect the total detected deforestation compared to methods with larger minimum mapping units. 
This is because small clearings grow into larger clearings over time and then become detectable 
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Figure 2: Digitized non-forest areas from May 2016 and May 2018 Sentinel-2 imagery in two 
villages forest reserves in Kilosa district.



with other approaches. However, mapping small clearings and directing forest patrol teams to those 
small clearings could help prevent them from growing larger. 

Therefore, it is recommended to digitize all clearings of at least 0.25 hectares and above, giving a 
minimum size of at least 25 Sentinel-2 pixels per polygon. Smaller polygons can still be included, 
but all clearings 0.25 hectares or greater must be digitized. Some experimentation in Kilosa 
suggests that clearings 0.25 hectares and above account for 95% of the area cleared in a given year.

Calculating Deforestation Statistics
Starting forest areas

1. The forest area(s) shapefile should have unique names for each unique forest area. However,
if the forest area(s) shapefile has multiple polygons for the same forest name, e.g. a village 
has more than one village forest reserve, then use “Dissolve...” from “Geoprocessing Tools” 
from the “Vector” menu to create a new dissolved version of the forest areas where the 
forest name is selected as the dissolve field. 

2. Open the dissolved shapefile data table for the forest(s) of interest, turn on editing and click 

on the “New Field” button .  Create a decimal field called ‘forest_ha’ as shown below:

3. Select the new field from the field selector at the top left of the table and enter the formula 

as shown: 

4. Click on “Update All”. The area in hectares for each forest polygon should appear in the 
table under the ‘forest_ha’ field. 

5. Right click on the dissolved forest area(s) layer and select “Export” and then “Save Feature 
as...”. Select CSV for the Format and save file with an appropriate name. 

Intersect non-forest polygons with forest area polygon(s)

1. From the “Vector” menu, select “Geoprocessing” and then “Intersection...”
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2. For the Input Layer, select the digitized non-forest area polygon file. For the Overlay layer, 
select the forest area(s) polygon file. Choose an appropriate name for the output file and 
Click Run. If an error occurs, run the fix geometry tool first on one or both layers.

3. Open the new intersection file data table. For each non-forest polygon within a forest area of
interest, the name of the forest should now be associated with that polygon. Any non-forest 
areas outside of forests or interests perhaps drawn by mistake, are no longer in the table.

Add a an area field for the intersected non-forest areas

1. Follow the process described in the start of this section to create a new field called 
‘clear_ha’ in the intersected non-forest area shapefile created in the last step and calculate 
the hectares for all the polygons in the file. 

Create a pivot table with Group Stats

1. Select “Manage and Install Plugins...” from the “Plugins” menu. Search for ‘Group Stats’. 
Select the plugin and click Install Plugin. This only needs to be done once.

2. From the “Vector” menu, select “Group Stats”.

3. Select the intersected shapefile from the Layers dropdown list. Then drag the ‘year’ field to 
the Columns section and drag the ‘name’ field to the Rows section. Drag the “clear_ha” field
to the Value section and then the sum calculation to the Value section. Click Calculate.

4. A new table should appear to the left with rows for each village and columns for each year. 
The values for the first year are the total non-forest at the beginning of the analysis and the 
values for each year after represent the total forest loss from the previous year to that year.

5. From the “Data” menu, select “Save All to CSV File” and give the file an appropriate name. 

Calculate Annual Deforestation Rates

1. Open the two CSV files in Excel or similar and sort both by forest name. Copy the 
“forest_ha” column from the forest areas spreadsheet to the non-forest areas spreadsheet and
insert it just after village name.

2. For each year in the analysis, create a column calculating the number of hectares of forest 
remaining in that year by subtracting that year’s and all previous years’ non-forest areas 
from the total forest area.

3. Calculate the deforestation rate for each time period as follows: 

Deforestation rates should be calculated as per Puyravaud, 2003:

 r=
1

t 2−t1

ln (
A2

A1
)  

Where:

r Annual deforestation rate; %

t 1, 2, 3 … T, an analysis year;
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A Forest area at time t; ha

ln Natural Log 
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